Difference between revisions of "Release Planning for Samba 4.5"

(Samba 4.5.3)
(Samba 4.5.3)
Line 16: Line 16:
 
<small>('''Updated 19-December-2016''')</small>
 
<small>('''Updated 19-December-2016''')</small>
  
* Monday, December 19 2016 - '''Samba 4.5.3''' has been released as a Security Release in order to address
+
* Monday, December 19 2016 - '''Samba 4.5.3''' has been released as a Security Release in order to address the following CVEs:
[https://www.samba.org/samba/security/CVE-2016-2123.html CVE-2016-2123] (Samba NDR Parsing ndr_pull_dnsp_name Heap-based Buffer Overflow Remote Code Execution Vulnerability), [https://www.samba.org/samba/security/CVE-2016-2125.html CVE-2016-2125] (Unconditional privilege delegation to Kerberos servers in trusted realms) and [https://www.samba.org/samba/security/CVE-2016-2126.html CVE-2016-2126] (Flaws in Kerberos PAC validation can trigger privilege elevation).
+
*[https://www.samba.org/samba/security/CVE-2016-2123.html CVE-2016-2123] (Samba NDR Parsing ndr_pull_dnsp_name Heap-based Buffer Overflow Remote Code Execution Vulnerability),
 +
* [https://www.samba.org/samba/security/CVE-2016-2125.html CVE-2016-2125] (Unconditional privilege delegation to Kerberos servers in trusted realms) and  
 +
* [https://www.samba.org/samba/security/CVE-2016-2126.html CVE-2016-2126] (Flaws in Kerberos PAC validation can trigger privilege elevation).
 
   [https://www.samba.org/samba/history/samba-4.5.3.html Release Notes Samba 4.5.3]
 
   [https://www.samba.org/samba/history/samba-4.5.3.html Release Notes Samba 4.5.3]
  

Revision as of 09:27, 19 December 2016

Samba 4.5 is the Current Stable Release Series.

All known bugs


Samba 4.5.4

(Updated 19-December-2016)

  • Wednesday, January 18 2017 - Planned release date for Samba 4.5.4

Samba 4.5.3

(Updated 19-December-2016)

  • Monday, December 19 2016 - Samba 4.5.3 has been released as a Security Release in order to address the following CVEs:
  • CVE-2016-2123 (Samba NDR Parsing ndr_pull_dnsp_name Heap-based Buffer Overflow Remote Code Execution Vulnerability),
  • CVE-2016-2125 (Unconditional privilege delegation to Kerberos servers in trusted realms) and
  • CVE-2016-2126 (Flaws in Kerberos PAC validation can trigger privilege elevation).
 Release Notes Samba 4.5.3

Samba 4.5.2

(Updated 07-December-2016)

  • Wednesday, December 7 2016 - Samba 4.5.2 has been released
 Release Notes Samba 4.5.2

Samba 4.5.1

(Updated 26-October-2016)

  • Wednesday, 26 October 2016 - Samba 4.5.1 has been released
 Release Notes Samba 4.5.1

Samba 4.5.0

(Updated 07-September-2016)

  • Wednesday, 07 September 2016 - Samba 4.5.0 has been released
 Release Notes Samba 4.5.0

Samba 4.5.0rc3

(Updated 29-August-2016)

  • Monday, 29 August 2016 - Samba 4.5.0rc3 has been released
 Release Notes Samba 4.5.0rc3

Samba 4.5.0rc2

(Updated 29-August-2016)

  • Wednesday, 10 August 2016 - Samba 4.5.0rc2 has been released
 Release Notes Samba 4.5.0rc2

Samba 4.5.0rc1

(Updated 28-July-2016)

  • Wednesday, 28 July 2016 - Samba 4.5.0rc1 has been released
 Release Notes Samba 4.5.0rc1