Difference between revisions of "Distribution-specific Package Installation"

m (Updated old-stable / stable / testing)
(Update Ubuntu versions)
Line 42: Line 42:
 
= Ubuntu =
 
= Ubuntu =
  
== 12.04 Precise Pangolin ==
+
== 12.04 Precise Pangolin (LTS) ==
  
 
Packages in 12.04 are very outdated, don't use them!
 
Packages in 12.04 are very outdated, don't use them!
  
  
 +
== 14.04 Trusty Tahr (LTS) ==
  
== 13.10 Saucy Salamander ==
+
  # apt-get install samba
 
 
  # apt-get install samba4
 
 
 
Note: Packages are of Samba version 4.0.3
 
  
 +
Note: Packages are of Samba version 4.1.6, see [http://packages.ubuntu.com/trusty-updates/samba http://packages.ubuntu.com/trusty-updates/samba].
  
  
== 14.04 LTS Trusty Tahr ==
+
== 15.10 Wily Werewolf ==
  
 
  # apt-get install samba
 
  # apt-get install samba
  
Note: Packages are of Samba version 4.1.6 See [http://packages.ubuntu.com/trusty/samba http://packages.ubuntu.com/trusty/samba]
+
Note: Packages are of Samba version 4.1.6, see [http://packages.ubuntu.com/wily-updates/samba http://packages.ubuntu.com/wily-updates/samba].
 
 
 
 
 
 
 
 
  
 
= FreeBSD =
 
= FreeBSD =

Revision as of 10:40, 13 February 2016

Introduction

This guide lists the necessary steps to install binary packages of Samba on selected distributions and mentions known pitfalls.



CentOS 6

# yum install samba4

Note: Packages are of Samba version 4.0.0!



Debian

Wheezy (old-stable)

Packages in Wheezy are very outdated, don't use them!

Note: On Wheezy backport Samba 4.1.17 is available: See https://packages.debian.org/wheezy-backports/samba See http://backports.debian.org/Instructions/ for information about how to add backports to your sources.list and how to install packages.


Jessie (stable)

# apt-get install samba

Note: Packages are of Samba version 4.1.17. See https://packages.debian.org/jessie/samba


Stretch (testing)

# apt-get install samba

Note: Packages are of Samba version 4.1.17. See https://packages.debian.org/stretch/samba

Ubuntu

12.04 Precise Pangolin (LTS)

Packages in 12.04 are very outdated, don't use them!


14.04 Trusty Tahr (LTS)

# apt-get install samba

Note: Packages are of Samba version 4.1.6, see http://packages.ubuntu.com/trusty-updates/samba.


15.10 Wily Werewolf

# apt-get install samba

Note: Packages are of Samba version 4.1.6, see http://packages.ubuntu.com/wily-updates/samba.

FreeBSD

# pkg install net/samba41

Note: If you want to use the idmap_ad Winbind backend (on e.g. an AD Member Server), you have to build the port by hand and select the EXP_MODULES configuration option!