Difference between revisions of "Distribution-specific Package Installation"

m (changed version number to 4.1.9)
m (Wheezy (stable))
Line 23: Line 23:
 
Packages in Wheezy are very outdated, don't use them!
 
Packages in Wheezy are very outdated, don't use them!
  
Note: On Wheezy backport Samba 4.1.9 is available: See [https://packages.debian.org/de/wheezy-backports/samba https://packages.debian.org/de/wheezy-backports/samba]
+
Note: On Wheezy backport Samba 4.1.11 is available: See [https://packages.debian.org/wheezy-backports/samba https://packages.debian.org/wheezy-backports/samba]
 
 
 
 
  
 
== Jessie (testing) ==
 
== Jessie (testing) ==

Revision as of 17:43, 12 November 2014

Introduction

This guide lists the necessary steps to install binary packages of Samba on selected distributions and mentions known pitfalls.



CentOS 6

# yum install samba4

Note: Packages are of Samba version 4.0.0!



Debian

Wheezy (stable)

Packages in Wheezy are very outdated, don't use them!

Note: On Wheezy backport Samba 4.1.11 is available: See https://packages.debian.org/wheezy-backports/samba

Jessie (testing)

# apt-get install samba

Note: Packages are of Samba version 4.1.9. See https://packages.debian.org/de/jessie/samba



Ubuntu

12.04 Precise Pangolin

Packages in 12.04 are very outdated, don't use them!


13.10 Saucy Salamander

# apt-get install samba4

Note: Packages are of Samba version 4.0.3


14.04 LTS Trusty Tahr

# apt-get install samba

Note: Packages are of Samba version 4.1.6 See http://packages.ubuntu.com/trusty/samba



FreeBSD

# pkg install net/samba41