Difference between revisions of "Distribution-specific Package Installation"

m (Fixed typo)
(Changed distro order (newer first), updated FreeBSD version, removed Ubuntu Samba version information (was outdated and makes no sense to mention it here. The user sees the version when installing. Nobody maintains this information here))
Line 11: Line 11:
 
= Red Hat Enterprise Linux / CentOS / Scientific Linux =
 
= Red Hat Enterprise Linux / CentOS / Scientific Linux =
  
== Version 6 ==
+
== Version 7 ==
  
 
  # yum install samba4
 
  # yum install samba4
  
Because of the missing MIT Kerberos support, you can not install the Samba packages provided in Red Hat Enterprise Linux 6 as a Samba AD DC. As alternative:
+
Because of the missing MIT Kerberos support, you can not install the Samba packages provided in Red Hat Enterprise Linux 7 as a Samba AD DC. As alternative:
 
* build Samba. For details, see [[Build_Samba_from_Source|Build Samba from Source]].
 
* build Samba. For details, see [[Build_Samba_from_Source|Build Samba from Source]].
 
* use 3rd-party packages with AD support from a trusted source.
 
* use 3rd-party packages with AD support from a trusted source.
Line 21: Line 21:
  
  
== Version 7 ==
+
== Version 6 ==
  
 
  # yum install samba4
 
  # yum install samba4
  
Because of the missing MIT Kerberos support, you can not install the Samba packages provided in Red Hat Enterprise Linux 7 as a Samba AD DC. As alternative:
+
Because of the missing MIT Kerberos support, you can not install the Samba packages provided in Red Hat Enterprise Linux 6 as a Samba AD DC. As alternative:
 
* build Samba. For details, see [[Build_Samba_from_Source|Build Samba from Source]].
 
* build Samba. For details, see [[Build_Samba_from_Source|Build Samba from Source]].
 
* use 3rd-party packages with AD support from a trusted source.
 
* use 3rd-party packages with AD support from a trusted source.
Line 35: Line 35:
 
= Debian =
 
= Debian =
  
== Wheezy (old-stable) ==
+
== Stretch (testing) ==
  
Packages in Wheezy are very outdated, don't use them!
+
# apt-get install samba
  
Note: On Wheezy backport Samba 4.1.17 is available: See [https://packages.debian.org/wheezy-backports/samba https://packages.debian.org/wheezy-backports/samba]
+
Note: Packages are of Samba version 4.1.17. See [https://packages.debian.org/stretch/samba https://packages.debian.org/stretch/samba]
See http://backports.debian.org/Instructions/ for information about how to add backports to your sources.list and how to install packages.
 
  
  
Line 52: Line 51:
  
  
== Stretch (testing) ==
+
== Wheezy (old-stable) ==
  
# apt-get install samba
+
Packages in Wheezy are very outdated, don't use them!
  
Note: Packages are of Samba version 4.1.17. See [https://packages.debian.org/stretch/samba https://packages.debian.org/stretch/samba]
+
Note: On Wheezy backport Samba 4.1.17 is available: See [https://packages.debian.org/wheezy-backports/samba https://packages.debian.org/wheezy-backports/samba]
 +
See http://backports.debian.org/Instructions/ for information about how to add backports to your sources.list and how to install packages.
  
  
Line 64: Line 64:
 
= Ubuntu =
 
= Ubuntu =
  
== 12.04 Precise Pangolin (LTS) ==
+
== 15.10 Wily Werewolf ==
  
Packages in 12.04 are very outdated, don't use them!
+
# apt-get install samba
  
  
Line 74: Line 74:
 
  # apt-get install samba
 
  # apt-get install samba
  
Note: Packages are of Samba version 4.1.6, see [http://packages.ubuntu.com/trusty-updates/samba http://packages.ubuntu.com/trusty-updates/samba].
 
  
  
 +
== 12.04 Precise Pangolin (LTS) ==
  
== 15.10 Wily Werewolf ==
+
  # apt-get install samba4
 
 
  # apt-get install samba
 
  
Note: Packages are of Samba version 4.1.17, see [http://packages.ubuntu.com/wily-updates/samba http://packages.ubuntu.com/wily-updates/samba].
+
Packages in 12.04 are very outdated (3.6.x), don't use them!
  
  
Line 90: Line 88:
 
= FreeBSD =
 
= FreeBSD =
  
  # pkg install net/samba41
+
  # pkg install net/samba44
  
 
Note: If you want to use the '''idmap_ad''' Winbind back end (on e.g. an AD Member Server), you have to build the port by hand and select the '''EXP_MODULES''' configuration option!
 
Note: If you want to use the '''idmap_ad''' Winbind back end (on e.g. an AD Member Server), you have to build the port by hand and select the '''EXP_MODULES''' configuration option!

Revision as of 01:01, 18 December 2016

Introduction

The following is a distribution-specific list of commands to install Samba.

Note, that the list of commands is neither provided nor actively verified by the Samba team. If you see any missing packages or incorrect package names, please update the command or send the information to the Samba mailing list.



Red Hat Enterprise Linux / CentOS / Scientific Linux

Version 7

# yum install samba4

Because of the missing MIT Kerberos support, you can not install the Samba packages provided in Red Hat Enterprise Linux 7 as a Samba AD DC. As alternative:

  • build Samba. For details, see Build Samba from Source.
  • use 3rd-party packages with AD support from a trusted source.


Version 6

# yum install samba4

Because of the missing MIT Kerberos support, you can not install the Samba packages provided in Red Hat Enterprise Linux 6 as a Samba AD DC. As alternative:

  • build Samba. For details, see Build Samba from Source.
  • use 3rd-party packages with AD support from a trusted source.



Debian

Stretch (testing)

# apt-get install samba

Note: Packages are of Samba version 4.1.17. See https://packages.debian.org/stretch/samba


Jessie (stable)

# apt-get install samba

Note: Packages are of Samba version 4.1.17. See https://packages.debian.org/jessie/samba


Wheezy (old-stable)

Packages in Wheezy are very outdated, don't use them!

Note: On Wheezy backport Samba 4.1.17 is available: See https://packages.debian.org/wheezy-backports/samba See http://backports.debian.org/Instructions/ for information about how to add backports to your sources.list and how to install packages.



Ubuntu

15.10 Wily Werewolf

# apt-get install samba


14.04 Trusty Tahr (LTS)

# apt-get install samba


12.04 Precise Pangolin (LTS)

# apt-get install samba4

Packages in 12.04 are very outdated (3.6.x), don't use them!



FreeBSD

# pkg install net/samba44

Note: If you want to use the idmap_ad Winbind back end (on e.g. an AD Member Server), you have to build the port by hand and select the EXP_MODULES configuration option!